Hi everyone,

I have completed my trial and then got an email saying it has been converted to a Vroom and all I had to do was click the link below. When I click the link it says 'link is invalid'. Could anyone help me access my Vroom.



Views: 1110

Reply to This

Replies to This Discussion

Donna, the transition to a 3 seat free room is not working right now.   We'll update you when the issue is resolved.  Sorry for the inconvenience.

Thank you for replying. Much appreciated.


Hi Valerie.  Has this bug been fixed? I tried using my converted 3-seat VRoom and it's not working either. I'm going to be presenting on Thursday and would love to practice.  Thanks!

Hi Shayne. Did you manage to sort your Vroom out. I still can't access one.


Nope, and haven't heard from anyone that could help me. Shame...

Thank you x

Any updates on this? Blackboard is notoriously slow (read: terrible) when it comes to just the basics of tech support, but 4+ months of this same error seems aggressively lax even by their "standards." 

Never did hear back from anyone. I tried contacting directly, too. No luck.

My toplist of Blackboard support delays is lead by a 10 month taking reaction for one of my customers, posted 3 days after they signed a Collaborate contract..It did come together with the question, why the customer did cancel the renewal of his contract aftr 9 months. Too late :-) 

My hint on this issue:

At the time, where WeCollaborate was opened, Blackboard cancelled all vRooms requesting anybody to resign for another trial. Did you try that?


Hi Mero,

I did try that but still the vroom wouldn't work at the end. Thanks for replying.


Hi Guys,

Is the free Vroom for 3 no longer available?


Tony Smith

It doesn't seem to be, Tony. Nobody from Collaborate has every replied to this problem.


The Learning Revolution

© 2022   Created by Steve Hargadon.   Powered by

Badges  |  Report an Issue  |  Terms of Service